Can't use fetech in mikrotik to update ip

In mikrotik x86 router, i want to use script to update the ddns ip with the tool fetch, it’s command like this [ fetch url=“<>&password=<here is my token>&myipv4=<here is my ip>” ] , it alway return “failure: closing connection: <401 Unauthorized> (4)”, but i can use the same url success in rest tool , it return good. what is the problem and how can i resolve, thks.

Dear moritenw,

welcome to deSEC!

In the snippet that you posted, it seems that your URL is missing the password parameter. Also, make sure you are using a token (created on our website) as a password. Your account password cannot be used here.


I have set the password in the actual url, here just show the placehold.i use the same url in two way, one is ok, another is not working.

now it can work in mikrotik after I recreate another account. maybe before try too much in fail block by server ?

Currently, deSEC does not use such a throttling or blocking mechanism.