FritzBox only updating ipv6 address?

Hey there, longtime fan of your service here.

I recently had to troubleshoot my FritzBox setup since I was not getting my IPv4 updated on my domain (which I didn’t have to touch for some years).
Thought I write my findings down for anyone having similar issues.

My FritzBox (Fritz!OS 7.50) seemed to not update my wan ipv4 adress lately, which led me to investigate.

A few weeks ago I tried also adding my public ipv6 address to my domain, which caused some troubles for my setup. And was discarded therefore (back to the or so I thought). But something seemed to have been stuck with my FritzBox, or the serivce changed its defaults?

Next time my provider decided it was time for a new public ip, my FritzBox did not update the wan IPv4 address accordingly. Instead it only passed on my IPv6 address???

I tried it in combination with other factors (rebooted, deactivated dyndns service, manual update via webbrowser). But to no avail, the FritzBox either only updated my IPv6 or IPv6 and IPv4 address in parallel…

Shortly after registering for the forum I found a mention of the new implemented options Determine IP Address(es)

Which showed me what I needed to know.
To only update my IPv4 public ip I had to use the following as my update-url:<ipaddr>&myipv6=

Now it works as before, only updating my IPv4 public ip after each reconnect.

solved when submitted

Great that you found the solution! I just want to point out that this URL syntax is not new; it’s been like that for at least 5 years. (Only the preserve part is new, but you don’t seem to be using that.)

Stay secure,